illu Help Desk
English
Search
⌃K
Links
💻

Technical Requirements

Desktop Web Application
To use illu, you can access our web application best from Google Chrome.
If you dont have Google Chrome yet, you can download it here​
Android Requirements
We support any Android device running Android 10 or higher. To get the best experience out of your mobile device, we recommend staying up to date on new versions.
If you don't know what version your device is running, you can check in your phone settings.
iOS Requirements
If you have an iOS device you can run illu by downloading our mobile applications here. Your device just needs to be running iOS 11 or higher.
If you don't know what version your device is running, you can check in your phone settings.
​
​